Solved

Canon printer will not connect to T-Mobile 5G Gateway home internet


Userlevel 2
Badge

I have the Arcadyan KVD21 Gateway and a Canon PIXMA TR4520 printer. I have tried multiple methods to connect the printer to the T-Mobile wifi network and am still unsuccessful. Currently, I am attempting setup using the Canon Wi-Fi Connection Assistant. In Network Settings, the T-Mobile network encryption type shows up as Do Not Use. Is there a way to change the encryption type on the network? Would that enable the printer to access the T-Mobile wifi? Any and all suggestion welcome. I have tried T-Mobile tech support, but they cannot help, saying it's a printer issue.

icon

Best answer by SSW 15 September 2022, 02:51

View original

47 replies

I am having the same issue and cannot get it to work using any of the solutions above.  I have a Canon TR4520 and just got the T-Mobile gateway tower.  I can see my Wi-Fi network; however, it doesn’t let me enter a password.  T-Mobile connects me to Canon, and Canon wants $20 just to speak with me.  Has anyone found a solution?

same problem

 

The only problem with switching the WPA2/WPA3 to WPA/WPA2 is that if you have a new 5g phone it won’t connect to home internet. I had to connect my old phone to switch it back. And it made me have to reset all the devices I had connected to it.

Cannot connect Pixma 3600 to T-Mobile 5G network… this is absolutely ridiculous problem!  New printer, brand new connection with TMobile, and here I am again, NO working printer! What the F!!!

is there ANY printer in this world, that connects to Tmobiles new wireless Internet?  And why doesn’t anyone get help from Canon, nor T-Mobile? No one knows anything in the companies that make these electronics? This is not supposed to be rocket science! 
im furious, I need my printer to work right now. And no, not changing settings for lower speeds and lower security. That is not the way this is supposed to work. 
appreciate the help that is offered here, it is at least more than we get from the service provider!

For my Pixma MG5420, I had to change the WPA version on the Tmobile gateway app (Network tab, select your wifi network, under WPA version, change to WPA/WPA2 from WPA2/WPA3).  Then on the printer, go to Device Settings ->LAN settings, ->wireless lan setup, ->Other setup options, ->Standard setup,->select access point, → Directly enter the access point name, then manually enter your wifi network and the passcode.  Voila!  This is after a fruitless call to Tmobile tech support, which described the problem I had connecting to a printer problem, and transfer me to Cannon tech support, which never connected me to a live person, but instead directed me to their website, then hung up.

Thank you,  this fixed my problem.  I had absolutely no clue how to fix it 🤩

I don’t have the WPA option. Properties says WPA3-personal. What else can I do?

Badge

I found some advice saying I should log into my router and create a separate SSID for the 2.4 ghz band and connect my printer to that. I used the tmobile internet app to log into my router but the only choices were either the 5ghz band or the 2.4 ghz band. I have a 5g phone so I can’t just change my router to 2.4 ghz because then my phone won;t have a wifi connection. Does the D371 router allow you to broadcast two bands or offer some other way to log in and check advance settings? Thanks!

Userlevel 4
Badge +3

I found some advice saying I should log into my router and create a separate SSID for the 2.4 ghz band and connect my printer to that. I used the tmobile internet app to log into my router but the only choices were either the 5ghz band or the 2.4 ghz band. I have a 5g phone so I can’t just change my router to 2.4 ghz because then my phone won;t have a wifi connection. Does the D371 router allow you to broadcast two bands or offer some other way to log in and check advance settings? Thanks!

 

The “5G” of your phone has nothing to do with the WiFi bands (2.4 GHz or 5 GHz) that it can connect to….it’s referring to the cellular signals it can receive (N41, N71).  It shouldn’t have any problem connecting to a 2.4 GHz WiFi network that you set up.

I’m still having problems connecting my canon pixma mx472 to my T-Mobile home internet.   I’ve created another network for the printer and changed the settings on the T-Mobile internet app. I have a error connecting to the new access point

I looked everywhere for a solution. I didn’t find it until SSW showed me the light and the way. I have a canon pixma mx870 and a macbook retina 2015 setup. I followed his steps and the printer, mac and me be happy. the Mac was a test subject and it did not suffer. I did all the sweating and frustration.

I saw “the printer is connected” on the printer screen. I printed one sheet and tried another copy. oh no there was no copy! after staring off into the ether, I looked up the mac menu bar. the wifi icon was dimmed. I clicked on it selected my access name and entered my password. tried a print and oh happy day it worked! I had to get away from Apple Air Print. I finally got the full printing menu but please don’t ask me how I did it. but it was in the add a printer in system preferences/settings.

My canon pro 1000 works also.

 

I ended up getting a repeater and Wi-Fi extender and now it works 

Good you got it connected. Another thing came up. I had to choose between a more secure WPA3 or wireless printing. I connected back to my original settings. I had to login but I expected that. What I didn’t expect was one of my macs wasn’t connecting. I moved closer to the gateway and got connected. 
I had a feeling I could have more than one network. So I looked and found how to create another network. Its on the t mobile internet app under Network.  I can use this network for my wireless mac with WPA/WPA2 and 2.4 GHz. 
USB connected printers are heaven on earth. 

Yes I also had to setup another network in T-Mobile internet app for the printer using WPA/WPA2  2.4 GHZ

My printer is 10-15 years old. Maybe thats why it doesn’t work with WPA/WPA3. How old is your printer? For others who may be reading this, are your printers 1-2 years old?  Is there a connection issue with newer printers and other wifi connected devices?

here is another bit of grief. I’m connected with network I made but now the mac and printer are not connected. I switched to the default network and the mac and printer are working. strange days.

Userlevel 5
Badge +6

You can have more than one network in use.  I think the gateway allows up to five, but two should be enough.  One is the default network that the gateway came with.  The second is a 2.4 GHz network that you add with the T-Mobile Internet phone app.  Your devices can be connected to whichever works best for them.  The default network automatically selects 5 GHz or 2.4 GHz for each connected device.  The security is WPA2/WPA3.  Many devices will connect to it without issues.  Set the security on the second network (2.4 GHz) to WPA/WPA2.  Use this second network for devices that don’t connect to the default network.  In my case, my ancient computer and ancient printer are connected to the dedicated 2.4 GHz network.  My newer computer and most of my other devices are fine on the default network.  I can print from my newer computer to the ancient printer.

I set up a second network with WPA WPA3 and 2.4 GHz. Connected the printer and made several copies. Problem solved, not really. Later that night i tried to make prints but no succss. There was ! Alert Next to the printer i was using. Cancelled the print job looked for more alerts but found none. Tried to print again but the ! Alert came back. I shut down the mac for the night. This morning tried again. Turned on the printer and it went into print mode. I didn’t do print setup on the mac. Talk about delayed reaction time. There may be a bug somewhere in the mac. Its old and getting older. The printer is almost as old. Ghosts in the machines. 
BTW this all happened in the T Mobile default network. The second network will not connect the mac and printer. Fun times in old Bixby. 

I never thought that I would be writing a technical comment. But, here goes. After subscribing to my new T-Mobile network everything connected, with some effort, except my Canon MX922. I spent two days trying everything I knew to connect to my network. However, it would not allow me to enter a passphrase. It would simply ask my Network name and then proceed directly to the Access Point. It would not ask or allow me to enter my passphrase. Then, like all technically challenged people I decide to look on the WWW for “HOW TO” and HELP! Which led me here. After reading through a few replies, I realized that I wasn’t alone. CONFUSED. Bottom line, luckily I have an old Wi-fi repeater called “WiFiBlast.” I have no idea where I purchased it or if it even “truly” works. But, I connected it. Chose it as my Access Point. It allowed me to enter my passphrase. I selected a security option (I read through a few more comments for an idea) selected it and VOILA!!! I am connected. AFTER 2 DAYS!!! This shouldn’t be so difficult. But, such as life. Good luck!

My Canon Pixma iX6820 did not like the new T-Mobile Fast 5688W router either.  I spent many hours trying to solve the issue.  I put an ethernet expander and Powerline adaptors in the system and connected all with ethernet cables. It works great and no password is required! And the printer can be moved to locations away from the computer.

Same issue here for my HP DeskJet 3510

The answer given by SSW was key, “...I had to change the WPA version on the Tmobile gateway app (Network tab, select your wifi network, under WPA version, change to WPA/WPA2 from WPA2/WPA3).  Then on the printer, go to Device Settings ->LAN settings, ->wireless lan setup...”

This did help and my printer was able to be set up. However, I then started experience connectivity issues on my computer and I kept having to sign back in the Wifi every 10 mins or so. I’m not sure why. Perhaps I’ll have to switch it every time I need to print. Very annoying. I don’t understand the disconnect. Is T-mobile’s internet technology too advanced for the printers?

can someone please help me? My MX922 will not connect - it shows my wifi name but it does not let me enter a password. 

I had basically the same problem.  I called T-Mobile support and they had no success and said they were recommending updating the printer.

I have a canon mx920 and it would skip the password step and gave me an error message.  After reading the message above I scrolled down and found the manually enter the access point which then gave me the password screen to enter and this solved the problem solved.

 

Thanks SSW

Reply