Solved

Printer issue


Badge

Now that I have TMobile as my ISP, my printer needs to be connected to this new network. I have a testpage that instructs me to see if MAC address filtering is enableda and/or to add the MAC addresss of my printer to the list of permitted devices for my wireless router. Sooo...in trying to access the wireless network, there isnt a list on the tmobile wireless router page, to add. What am I missing?

icon

Best answer by bocaboy2591 17 April 2023, 13:15

View original

11 replies

Userlevel 5
Badge +9

@4Gina it should be pretty simple. I would download or find your existing driver/setup app for your printer. For example I have an Epson printer and it has a setup application. You need a way to tell the printer the ip address of your gateway. 

You might find the following YouTube general video helpful.

Let us know how it turns out.

Userlevel 6
Badge +7

@4Gina, forget about the MAC filtering. That page comes up when you can't connect to the wireless. Here’s what to try.

Your problem is pretty common among T-Mobile Internet users. This usually fixes the problem.

Try adding a new WiFi network for the printer. Launch the T-Mobile phone app and tap the Network tab on the bottom, then the “+” button on the lower right. Create a new 2.4 GHz WiFi network with a unique name (SSID), just for your printer, e.g. MyNetwork2. Make sure the WPA type is WPA/WPA2. This is different from your main network which, by default, is WPA2/WPA3. Now, scroll down the page of your new network and also make sure that the Hidden switch is set to Off. Scroll down to the Save button, tap it, and your gateway will reboot.

Now, go to your printer and clear out all of the information you have entered for your printer’s setup and then recreate your wireless connection to the new network you just created.

I’m dealing with the same issue with my Epson printer.  Setting up a new wifi network does not work, I’ve already tried that.  My new printer is practically useless now, and I don’t know what to do.  I’ve gone through both customer support lines, T-Mobile and Epson and it is the MAC Address filtering, T-Mobile reps stated they have no control on turning it off.  

Just got my TMobile Home Internet Gateway.

I have a old Brother multifunction printer.  Initially, I just connected it to the TMobile network,  but nothing sees the printer.  

I had to use the Reset Network option on the printer to wipe all prior settings and IP address.

Then just added the printer to TMobile network and got a new IP address.

Added the "new" printer (new device IP address) to my phone and computer print services and now printing again. 

What is meant “ go to your printer and clear out all of the information you have entered for your printer’s setup”? Where does one do that? Thanks.

What is meant “ go to your printer and clear out all of the information you have entered for your printer’s setup”? Where does one do that? Thanks.

From the printer’s menu options.  On my Brother printer, there's a menu option for Network settings, which provides option to "reset network". 

Thanks for your reply. Got my Brother inkjet all-in-one connected thru its screw n. My little HP LaderJet P1102w doesn’t have a screen and I for the life of me cannot get it reinstalled on my computer or connected to my T-Mobile gateway.  For most of my things I prefer laser jet but for now I’m handcuffed!

@4Gina, forget about the MAC filtering. That page comes up when you can't connect to the wireless. Here’s what to try.

Your problem is pretty common among T-Mobile Internet users. This usually fixes the problem.

Try adding a new WiFi network for the printer. Launch the T-Mobile phone app and tap the Network tab on the bottom, then the “+” button on the lower right. Create a new 2.4 GHz WiFi network with a unique name (SSID), just for your printer, e.g. MyNetwork2. Make sure the WPA type is WPA/WPA2. This is different from your main network which, by default, is WPA2/WPA3. Now, scroll down the page of your new network and also make sure that the Hidden switch is set to Off. Scroll down to the Save button, tap it, and your gateway will reboot.

Now, go to your printer and clear out all of the information you have entered for your printer’s setup and then recreate your wireless connection to the new network you just created.

Your answer is 100% the best. Worked perfectly

 

Now that I have TMobile as my ISP, my printer needs to be connected to this new network. I have a testpage that instructs me to see if MAC address filtering is enableda and/or to add the MAC addresss of my printer to the list of permitted devices for my wireless router. Sooo...in trying to access the wireless network, there isnt a list on the tmobile wireless router page, to add. What am I missing?

Worked as described. This new network was able to see my printer.

For some reason, I cannot see a Network tab anywhere, whether on the T-Mobile app on my phone or my laptop. The only options I have are Home, Account, Bill, Shop, More. I’ve tried searching for ‘Network’ in all of these options to no avail. Very frustrating. 

My printer worked great on my T-Mobile internet until about a week ago. Now just frustrating attempts. Any solution to this would be greatly appreciated. Thank you!

Userlevel 5
Badge +8

@Mmoon the instructions above were written for the T-Mobile Internet app, which is different from the T-Mobile app.  However, the Internet app is going away soon, so you need the T Life app.  

T Life app instructions to create new 2.4 GHz network:

Connect (at the bottom) > Things (at the top) > tap your Gateway > tap Manage > under My Networks, you will see each one you already have. 

To create a new network, tap Network (at the top.)  Under My Networks, tap + Add Network to open the page to set up your new network.  Give it name (SSID) and a password; select the frequency band (2.4 GHz); select the WPA version (WPA/WPA2).  (Encryption mode is automatically set when you select a WPA version).  Tap Save at the bottom.

Home Internet Apps | T-Mobile 5G Home Internet

Reply