Solved

Texting issues when connected to WiFi

  • 28 August 2018
  • 60 replies
  • 6588 views

I've been having an issue for about a week now where as soon as my phone connects to Wifi, I begin having issues sending and receiving text messages. I've been having the same issue as well as my Girlfriend, her Mom, and her Daughter all having the exact same issues when on WiFi. This includes 4 different phones, 3 different Samsung models and an iPhone. All T-Mobile devices. This issue seems to only be with text messaging. No issues with calls or any type of Data or internet related App. Just sending and receiving text messages.

I called support last week because I was certain this was a known issue for many people, but was told it was not. I went through all the trouble shooting steps with the team and nothing they could do seemed to fix the issue. I cleared my cache, checked my data to ensure it was all setup correctly, I'm even now using a brand new Note 9 and still having the same issues. When I called originally I was using my s7 Edge.

I've taken a few photos where you can see the change.

When you're not on WiFi you can see the 4gLTE symbol next to the service indicator and it seems to work fine.

https://postimg.cc/image/xsv6evu2v/

As soon as I connect to WiFi, that 4gLTE symbol goes away. I'm pretty sure it never did this before.

https://postimg.cc/image/r2ep5gemv/

Then when sending I get these errors..

https://postimg.cc/image/nisrfmwhj/

On top of the issue with sending failures, sometimes after taking minutes to send, the person who is receiving the message will get up to 4 copies of the same message. I will also receive up to 4 copies of a message when getting texts. So it's an issue with incoming and outgoing.

This seems to be something that change with an update/service. Not the device or anything. When I got my note 9, the 1st thing it had me do was connect  to WiFi and I immediately noticed this same issue (no 4gLTE symbol) before installing a single APP or anything.

I'd like to point out, this is not always an issue. Most time it works pretty well, however it's a daily occurrence for the last week. Happens while I have full cell and 500MB+ WiFi service.

Please advise how this is to be resolved.

Thanks,

Matthew

icon

Best answer by tmo_chris 5 September 2018, 17:05

If the messages are only failing when the phone is using the Wi-Fi calling, this is going to be something that we will need to open an engineering support ticket for. Please gather a few examples/date/time/numbers of the failures and contact us so our tech care folks can get a ticket opened up for you.

View original

60 replies

Userlevel 6

Do all the phones have this issue in the same wifi network?  Maybe the router is at fault.

This issue happens on all wifi networks. Home, gym, work. All secure and private networks. Same goes for all others.

Userlevel 6

if this is happening on all phones on all Wi-Fi networks then it would have to be an account issue. I did not see where all phones were on the same account however T-Mobile we need to address of the line settings and make sure that everything is refreshed and that there is no specific block or other issue on the account level.

Ignoring the other phones. What can be done to resolve my issue? It seems to be getting worse.

Matthew

Userlevel 5

What specific phone are you using? Are you on one of the Samsung phones or on the iPhone? I want to see if the issue persists if we turn off Wi-Fi calling.

Hi,

I've been having the same problem for a year or more, but finally relying on texting enough to try to debug it! Regardless of wifi network I connect to, my ability to send or receive texts becomes very unreliable if I'm connected to wifi - phone will try for several minutes to download or upload a message before giving an error message. If I turn off wifi, I can then send/receive texts.

My phone is a Moto G5 Plus with Android 7.0. I'm using Messages for texting.

I have wifi calling turned on and set to "wifi preferred" - though I've just changed the latter setting to "cellular preferred" and will see in the morning if that helps. If not, my next step will be to turn off wifi calling and see what happens. Any suggestions will be appreciated!

Thanks,
Brian

Userlevel 5

Hey @magenta6038965 

I appreciate you doing all of that troubleshooting 😊 How did things turn out?

Hi tmo_chris,

"cellular preferred" was at least as bad or worse - no texts were getting through while I was on a wifi network. Today I had wifi calling turned off, though, and texts are getting through promptly. So it's definitely a bad interaction between wifi calling and texting - any suggestions how to fix?

One of my work locations is in a building with solid wifi but poor cell service, so it's important for me to be able to enable wifi calling when I'm there - and still receive texts!

Thanks,
Brian

Userlevel 5

If the messages are only failing when the phone is using the Wi-Fi calling, this is going to be something that we will need to open an engineering support ticket for. Please gather a few examples/date/time/numbers of the failures and contact us so our tech care folks can get a ticket opened up for you.

Any resolution to this? It is happening daily on our phone - was a Samsung S5, now a Samsung S8.

Userlevel 5

It doesn't look like OP or the other folks came back after I refereed them to call our tech care folks over the phone so it is possible that having the ticket filed fixed the issue. I would recommend that you do the same when you get a chance @soccer22

@tmo_Chris,

I'm having the same issue with my S9 where SMSs Fail To Send... until I disable my wifi connection. Then they send fine.

Seems like a lot to submit that information you requested... I've been waiting for someone else to help you all with research-- I've been checking back for a solution....

Nonetheless, if this still has not been solved, I'll  go ahead and "bite the bullet" and collect/send that data.

Userlevel 5

I know it's a lot @pjwatty 😥 but this is typically account specific and if we fix it for one person, it may not fix it for everyone. The best bet is to Contact Us with that information so that our folks over the phone can get a ticket opened for you specifically.

Just switched to T-mobile and my texting over

wifi never worked. This is on all 4 devices I own.

Texting period is an issue over the T-Mobile network. Very slow and often fails to send. Wife is getting very frustrated and asking me to go back to ATT. Any help in fixing this would be great.

To whomever,

I'm glad I wasn't the only one dealing with this issue and it seems to be the exact same issue. Regardless if I am on a Wifi at work, school, home, etc., in order to send a text, I have to disable my wifi connection (and sometimes turn airplane mode on and off again) to send a text. It is quite frustrating since I cannot use Messages for web as seamlessly as I'd like because I'm always interrupted ~20 seconds later with a notification on my phone saying my text failed to send. My work place is similar as someone else mentioned above; great Wifi signal with little to no cell service so it's crucial for Wifi calling/texting to work properly.

I am using a Galaxy S7.

Hopefully this can be addressed soon.

Regards

Userlevel 4
Badge +9

Hey there, are you still using your AT&T phones or did you purchase new ones from T-Mobile?  If you are using unlocked phones, you might want to check your APN settings and make sure it is configured properly for MMS.  An extra note that isn't mentioned in many places where the T-Mobile APN can be found is that the MMS Port can be set at 80.  I have seen this solve many types of issues with sending and receiving MMS using unlocked devices.

Userlevel 4
Badge +9

Hi there! I'm really sorry you're having a rough time getting those messages out.  Are you using a T-Mobile device or is it unlocked from another carrier?

Thank you for the response.

I actually just upgraded to a different phone after that message (S7 to a

OP6). Both were/are unlocked. I don't seem to be having any issues with the

OP6 as of now. I will keep in mind toset my MMS port to 80 if I run into

troubles again.

Regards

Well, disregard that last statement.

I wasn't having troubles the night before but this morning I am.

I get a message when I switch airplane mode on and off that says "SIM Card

not provisioned". I'm not sure if this is related but I'll research it now.

Userlevel 4
Badge +9

Are you using the same SIM from your previous device?

Yes I am.

Userlevel 4
Badge +9

If it is saying the SIM isn't provisioned, it can mean that it's not activated.  Is there a chance that T-Mo could have switched the SIM number when you switched phones?  Are you able to make/receive calls/texts at all from it, or access data?

So turns out the SIM not provisioned was for a different SIM card (the

person I bought the phone from left their old SIM in one of the slots). I

took that out and I didn't get that notification anymore with just my

active SIM.

I think I've figured out what the issue is:

I'm reading that in order for SMS/MMS to function properly over Wifi, Wifi

calling must be active. When I active Wifi calling while I have cell

service/mobile data, a smooth transition occurs and I am able to use

SMS/MMS over Wifi. Now, what ends up happening is my Wifi calling will

randomly become disabled (often accompanied with a "Error: Wifi calling

cannot be set up... something, something missing 911 address"). Whenever

this happens is when I notice my SMS/MMS over Wifi stops working (and I'll

notice Messages for Web will say "Not connected to phone"). I'll still be

connected to the Wifi so apps like Chrome, Gmail, Outlook, etc still work

but SMS/MMS won't work until that Wifi calling is reset... somehow. Usually

I reset it by switching airplane mode on and off and allowing that initial

connection to happen again but when I'm in an area (like my work/lab) that

doesn't have cell service, I cannot do this little trick. Either way, I'm

not sure what's causing the Wifi calling to randomly become disabled but I

believe that is the heart of the problem because I noticed it this morning

at my house and now at work.

Maybe it's a bug? Anywho, can anyone else confirm this issue and if I

explained it properly? Maybe T-Mobile can address this (I'm guessing it's a

T-Mobile thing since this has occurred for me while using an unlocked

Samsung S7 and now an unlocked OnePlus 6).

Regards

I think the problem is not with the carrier

You can try activate developer settings in your phone.

And then check Keep Mobile Data Option, hope it can help ur problem

I have the same problem.  Test messages are stuck "sending" when connected to wifi.  Happens on different wifi networks (so not a wifi router issue).  This is an intermittent problem.  My phone is a Samsung Galaxy J7 connected to a T-Mobile LTE network.  Turning airplane mode off/on gets the messages to send.  But this is a serious problem.  You never know if your text messages have sent or not. 

There is a bug here for sure.  Looks like the issue was reported to the engineering team back in September.  Any progress to report or workarounds that can help us out?

Reply