Question

Home Internet - force firmware update?

  • 9 January 2021
  • 40 replies
  • 18465 views

Userlevel 1
Badge

We received the new 5G modem for Home Internet and are on the older firmware version 1.2003.03.0143. 

 

Is there anyway to trigger the update?

 

I've heard the new update can greatly speed up the modem but don't know if that's true.


40 replies

I got the new 6g modem today an it won't work because firmware needs updating i click update while I'm in the modem settings an it ask me for file to update it with . So mine will not work an call center is a joke 2hr waits never call back . It's a joke 

Still waiting for the next firmware update above .0168 so that it will resolve the issue with using VOIP services.  Customer Support has no release date 

Userlevel 7
Badge +15

Contact tech support.  They should be able to push a firmware update to it for you. 

I have firmware 1.2003.03.0178 and it seems unreliable. It constantly drops connection and I have to reset the device via the admin page.

New customer since 9/1/2021


My Internet Gateway has firmware 1.2101.00.1609  installed.


I'm a bit disappointed with the spotty connectivity, slow DNS, and buffering on 4K Ultra HDR video streaming testing. I opened a complaint ticket with the cellular engineers ( via 844-275-9310 ), and I was informed that my tower is still awaiting a 5G upgrade. That doesn't match with the promotional flyer in the mail. 😟 The guy I talked with on the phone was able to confirm the relative direction of the tower, so I do have it located in the best-facing window of the home. I have to say that the service and attention provided on that call were superb. ( It may have helped that he recognized my experience in wireless and LAN networking ).

I'm not sure how well that little appliance functions as a DNS server, but it is probably an extra useless hop. So, I manually changed my DNS server setting on the laptop to Google's 8.8.8.8, and that helped improve name resolution times quite a bit.

 

Userlevel 2
Badge +1

I was told recently by a T-Engineer to get the latest update, power off your tower for 30 minutes.  After that time power the gateway back up.  The gateway will automatically look for an update, if available it will down load it and install.

Userlevel 3
Badge

We received the new 5G modem for Home Internet and are on the older firmware version 1.2003.03.0143. 

 

Is there anyway to trigger the update?

 

I've heard the new update can greatly speed up the modem but don't know if that's true.

What do you think the latest firmware version is?

Userlevel 2
Badge +1

Yesterday, I received and installed the new 5G gateway, 5G21-12W-A.

Where can I find the latest firmware version?

Badge

We received the new 5G modem for Home Internet and are on the older firmware version 1.2003.03.0143. 

 

Is there anyway to trigger the update?

 

I've heard the new update can greatly speed up the modem but don't know if that's true.

Reboot or Factory Reset may work. Mine updated over night and now there is packet loss. I have no 5G so B66 is the only band I’m connected to but never have experienced packet loss till this update.

 

@rangerrick337 : In your browser go to 192.168.12.1 to login to the modem/router. See if the System|Upgrade button will take you from 1.2003.03.0143 to 1.2003.03.0168

We’ve had ours since late Feb. It’s on 1.2003.03.0168, but I can’t remember if I did the manual update or if it happened after a reboot.

@wildchld : What utility are you using that shows jitter and packet loss?

Badge

Still waiting for the next firmware update above .0168 so that it will resolve the issue with using VOIP services.  Customer Support has no release date 

I have been told they would have it by Wednesday, April 27, 2021, but the information I have received from Customer Service has not proved to be reliable.  I bought the Line-Link for VOIP and it took me several phone calls before someone told me it would not connect to 5 G.

I have been unable to get into the settings on my Gateway - how do you know what firmware you have?

 

Well today isn't over yet, so there is still hope for the upgrade.  As for accessing your gateway, from a PC or MAC go to. 192.168.12.1.  You should see the overview page.  On the very right side is Software Version.  The current version is 1.2003.03.0168.  So we want to see a higher number  for the new version that gets released.   Otherwise you can use the Home Internet App on your phone and at the bottom (android version) click on MORE and then click on GATEWAY INFORMATION.  The FIRMWARE VERSION is the first thing listed. 

Current 5G modems being shipped with firmware version 1.2003.03.0168 .

I'm afraid not just received my 3days ago

Current 5G modems being shipped with firmware version 1.2003.03.0168 .

Userlevel 3
Badge

Current 5G modems being shipped with firmware version 1.2003.03.0168 .

That’s noteworthy.

Can you take some screenshots of the web interface so we can compare and see what if anything has been updated?

I am still on 0143 myself.  A member, Stefan Knight, of the TMobile Home Internet FB group just received his 5G modem and posted his firmware version.  Here’s a link to the group in case you’re not familiar with them.  You may have to join to view the threads.

  https://www.facebook.com/groups/360887451937077

I did a factory reset and now I have 1.2101.00.1609

5G21 firmware update

 

Badge

We received the new 5G modem for Home Internet and are on the older firmware version 1.2003.03.0143. 

 

Is there anyway to trigger the update?

 

I've heard the new update can greatly speed up the modem but don't know if that's true.

Reboot or Factory Reset may work. Mine updated over night and now there is packet loss. I have no 5G so B66 is the only band I’m connected to but never have experienced packet loss till this update.

 

@rangerrick337 : In your browser go to 192.168.12.1 to login to the modem/router. See if the System|Upgrade button will take you from 1.2003.03.0143 to 1.2003.03.0168

We’ve had ours since late Feb. It’s on 1.2003.03.0168, but I can’t remember if I did the manual update or if it happened after a reboot.

@wildchld : What utility are you using that shows jitter and packet loss?

I started getting the packet loss when I got .0178 never was on .0168.

That’s a Speedtest from inside my Asus router…

 

 

I just tried it…. didn’t work for me.

Badge

Thank you for the info - I see that now.  I have been trying to look at the system part of the gateway and it asks for a log-on.  I use “admin” and the password on the bottom of the gateway, but it won’t let me log in and doesn’t give an option for help.  

Should I be able to log into that?

Maybe you changed the password at some point?  You can do a reset by pressing the button on the back of the unit but then you would have to do any setup you have done previously again. Doing the login gives you the ability to change the ssid name and passwords , etc . 

Contact tech support.  They should be able to push a firmware update to it for you. 

 

I tried that, they said they cannot push the update.. and it should be “completed” by 8/26.

 

It’s 8/26.

 

No firmware update.

 

 

Badge

Thanks for the info - very helpful.

Badge

@wildchld Hmmm - interesting. When I got the T-Mobile/Nokia device I was told by TM tech that the LAN/WAN ports were not active. Are you using ethernet or WiFi between your devices and your ASUS router? (We’re still using our reliable ASUS RT-N66U to connect to our ATT DSL modem because Hulu Live TV through Roku sees the TM Home Internet as a forbidden mobile hotspot.) 

 

Userlevel 3
Badge +2

@wildchld Hmmm - interesting. When I got the T-Mobile/Nokia device I was told by TM tech that the LAN/WAN ports were not active. Are you using ethernet or WiFi between your devices and your ASUS router? (We’re still using our reliable ASUS RT-N66U to connect to our ATT DSL modem because Hulu Live TV through Roku sees the TM Home Internet as a forbidden mobile hotspot.) 

 

I received my High Speed Gateway ten days ago.   It has firmware version 1.2003.03.0178.

 

The LAN ports are active.   I have an Orbi Router connected to one port in Access Point mode, and an 8 port switch connected to the other.

Reply