Solved

Home Internet - Port Forwarding not working

  • 4 October 2019
  • 32 replies
  • 19828 views

I received and configured my LTE Gateway, TM-RTL0102 about a week ago. It works almost perfectly. Speeds are solid, both up and down. Only problem is that port forwarding isn't working. I've got the virtual servers configured on the Gateway for my home security cameras and RDP to my office computer, but neither is working. Is this a feature that's not available yet? If not, I might have to hold up on using the service as it's definitely something I'd like to have working, especially the security cameras.

icon

Best answer by tmo_chris 9 October 2019, 16:59

Sorry it is still not working for you 😥 If you have a moment, this is the direct number to our Home internet support team 1-844-275-9310. Please give them a call when you have a moment and we can see if there is some advance troubleshooting that can be done.

View original

This topic has been closed for comments

32 replies

Userlevel 4

I cannot find any settings for port forwarding in the GUI. I do see NAT, UPnP and, ALG https://support.t-mobile.com/docs/DOC-39518#app8

Where specifically are you configuring the port forwarding?

The virtual server/NAT settings are port forwarding. For the internal IP just put the port you are forwarding. If it is a range I usually do 30 below the highest number.

It works. My xbox now has full upnp as well ad open nat unlike on the mobile hotspot through my phone. Port forwarding for mobile hotspot would be great

Userlevel 4

Glad you could get it working! Not sure we are gonna be able to do advanced network config stuff on a smartphone mobile hotspot as it is simply designed to provide internet to other devices and not networking.

Still not working for me. I've got ports 8080-8080 forwarding to port 80 of my desktop PC's static IP address. And 4009-4009 forwarding to port 3389 of the same IP for remote desktop access. These worked perfectly fine using my Spectrum coax cable modem/router, but not working on the LTE Gateway.

Userlevel 4

Sorry it is still not working for you 😥 If you have a moment, this is the direct number to our Home internet support team 1-844-275-9310. Please give them a call when you have a moment and we can see if there is some advance troubleshooting that can be done.

I'll try calling one of these evenings when I'm home. Or this Weekend.

Chris,

I was offered T-Mobile Home Internet Friday evening. The sales rep was very nice but could not answer some of my pressing questions. I understand as she wasn't trained at that level. I would prefer bridge mode for the gateway. I was told Sunday by Tech Support the Gen 1 gateways do not support. It is "rumored" that the next gen will support bridge mode but no confirm rumor or expected date. I access a single board controller and Node-Red from the outside now with a land DSL service. No problems there but T-Mobile is much faster at a lower cost if I change to VOIP. Tech Support told me they could not give me a static public IP as I have now. My after the sale research shows that LTE type Internet doesn't work the same and that's not going to happen. Even with a static public DHCP and a DDNS it looks like double NAT'ing is the only remote possible option. The bottom line is I need to be able to log into my Raspberry Pi and Node-Red port from anywhere. It looks like even with bridge mode the lack of an IP address I am still out of luck. I would not be so terribly opposed to a DDNS service but search engine research indicates this is not possible with T-Mobile LTE Home Internet. l I just don't think this is prime time unless unless you want to play on social media and check email. Please tell me I'm missing something. Regards, Alvin

A fee other things I have noticed is when I change the internal IP address in the virtual server, it locks all entries in to whatever I entered last. Ie. 7 entries for xx.x.130 to the xbox and 1 entry x.131 for the switch ranges. The 7 entries will all lock to .131.

Additionally, port forwarding does seem to work if I only have the 7 xbox entries and no other device connected to the network. They seem to work, even if double nat'd.

Userlevel 4

Hey @aes 

The folks over the phone are gonna know more about the service than I do personally and if they are saying that it is not going to work for what your needs, it may be best to hold off on our service 😥

@magenta10158371 - I posted the direct line to the home internet support folks above. Please give them a call for some advanced troubleshooting.

+1000 for bridge mode.

I am port forwarding for Plex access from the outside which seems to be working fine:

And then on the internal router another forward from 16824 to Plex port on my QNAP NAS.

The Plex settings indicate "Not available outside your network" but my iOS devices connect just fine.

For those who have reported it working I am a little confused, what are you using for the public IP?

I'm with you @jonsteinmetz​ it appears that the LTE Internet service uses IPV6 and I think that an port request is not reaching the LTE/WiFi device. Even with DMZ turned on and pointed to an internal box with open ports, I can see using "ShieldsUP!" by Gibson Research Corp that my public IP address is showing all ports closed and in stealth mode.

Reproduction steps

Public IP: While connected directly to the LTE/WiFi device, look up the public IP address via ipchicken or any other IP presentation service.

Port Scan: Scan for specific or all ports via "ShieldsUP!"

My current setup is that I am keeping my Century Link DSL and sharing both connections via a PFSense router. I map all incoming connections through the DSL side and set it up to prefer LTE for all outgoing connections. I was told that T-Mobile will be rolling out newer hardware to those who want it at some point. Hopefully that will connect to their 5G and that that will offer us public IPs. If not StarLink will hopefully offer service this year...

I noticed some of the posts are from a few months ago. Anyone know if Bridge mode is now available on the TM-RTL0102?

Talked to tech support for Home Internet last week. She was very forthright and appeared to be knowledgeable. This modem was put out quickly for the "trial" home Internet service. She stated that they've had a ton of feedback about the lack of bridge mode. She also confirmed that all the controls for port forwarding, virtual servers and DMZ were operative but not functional at all.

They are somewhat in a hold mode due to the Sprint acquisition. They plan to provide a high featured modem for the "5G" roll out but could not provide a time frame for that.

I've done extensive testing on the DMZ, virtual servers and Port Forwarding with not one scintilla of success. Now I know why.

One thing puzzles me is how Synology Quickconnect, Zoom, and Skype works w/o port forwarding, but it certainly does.  Maybe well known protocols are passed through without our control.

Hello T-Mo Subscribers and Support,

I am having the same problem. I love, Love, LOVE T-Mobile and said, "Oh-yeah, sign me up" when Home Internet became available! I really need the NAT Forwarding feature to work, PLEASE!!

Thanks and stay safe and healthy,

Digital Robert

Hello Again T-Mo Subscribers and Support,

I opened a support case with T-Mo Home Internet (regarding NAT Forwarding) and they told me someone would contact me in 72 hours. That was over two weeks ago (and no contact).

I called in again, today, to get an update on my case. The agent seemed to be reading from the notes on this ticket. The take-away seemed to be that further troubleshooting needed to be done (if nothing else testing the SIM or other hardware related issues). No mention of when any follow-up would occur.

I took to Google for more independent research and found this on T-Mo's Web site: (there should be a small screenshot just below)

Just in case the (above) screenshot is missing, here is the text:

"NAT Forwarding

While T-Mobile does not support setting up or using NAT Forwarding, the settings are available."

Here is the link to that Web page:

Web User Interface: T-Mobile LTE Wi-Fi Gateway | T-Mobile Support

I am now not clear how "more hardware troubleshooting is needed" in light of this publicly stated position of non-support?

I believe home internet service is new for T-Mo and maybe in the future NAT Forwarding will become supported.

Good luck and stay safe and healthy,

Digital Robert

I was able to get port forwarding to work. In my setup I use the T-Mobile Gateway → USG-3P → Home Network. In this case I have a router behind another router. In the home network I have a Plex Media server. Here’s the steps I used to get the Plex Media server to talk to devices outside (Internet) the home network.

  1. Change the IP address of the T-Mobile gateway from 192.168.1.1 to 192.168.1.2
  2. I left the USG-3P address range at 192.168.1.x
  3. Enabled port forwarding on the USG-3P so that 32400 would reach my Plex server. Essentially nothing changed on the USG-3P, this was what I had when it was connected to a Comcast modem.
  4. On the T-Mobile Gateway I enabled the DMZ and put the USG-3P into it.
  5. I disabled all Wifi capability of the T-Mobile Gateway, and only used a single LAN connection directly into the USG-3P.
  6. I disabled ALL firewall settings on the T-Mobile Gateway. I figured this is okay because the only outlet is directly into my USG-3P router that has all it’s firewall enabled. Again, all Wifi is disabled on the T-Mobile Gateway and the only outlet is a LAN port directly into the USG-3P which firewalls my home network.
  7. I set the virtual server routing on the T-Mobile Gateway for port 32400 to point to the USG-3P.

After that I was able to successfully get devices on the external Internet to talk to my Plex server. Logically it seemed that I would only either need to enable DMZ or Virtual Server, and it seemed like I shouldn’t have to disable all the T-Mobile Firewalls, but it wouldn’t work unless I did all the above steps. Again, I would not recommend this unless you have a dual router situation, you disable Wifi on the T-Mobile router, and you place your entire home network behind a second router that has the proper Firewall protections.

Userlevel 2
Badge +1

I don’t use this, but nice to see somebody figure it out. prob felt nice being able to see it working. right on :]

I was able to get port forwarding to work. In my setup I use the T-Mobile Gateway → USG-3P → Home Network. In this case I have a router behind another router. In the home network I have a Plex Media server. Here’s the steps I used to get the Plex Media server to talk to devices outside (Internet) the home network.

  1. Change the IP address of the T-Mobile gateway from 192.168.1.1 to 192.168.1.2
  2. I left the USG-3P address range at 192.168.1.x
  3. Enabled port forwarding on the USG-3P so that 32400 would reach my Plex server. Essentially nothing changed on the USG-3P, this was what I had when it was connected to a Comcast modem.
  4. On the T-Mobile Gateway I enabled the DMZ and put the USG-3P into it.
  5. I disabled all Wifi capability of the T-Mobile Gateway, and only used a single LAN connection directly into the USG-3P.
  6. I disabled ALL firewall settings on the T-Mobile Gateway. I figured this is okay because the only outlet is directly into my USG-3P router that has all it’s firewall enabled. Again, all Wifi is disabled on the T-Mobile Gateway and the only outlet is a LAN port directly into the USG-3P which firewalls my home network.
  7. I set the virtual server routing on the T-Mobile Gateway for port 32400 to point to the USG-3P.

After that I was able to successfully get devices on the external Internet to talk to my Plex server. Logically it seemed that I would only either need to enable DMZ or Virtual Server, and it seemed like I shouldn’t have to disable all the T-Mobile Firewalls, but it wouldn’t work unless I did all the above steps. Again, I would not recommend this unless you have a dual router situation, you disable Wifi on the T-Mobile router, and you place your entire home network behind a second router that has the proper Firewall protections.

 

I have the exact setup (even the firewall USG) as you and it's not working. 

Could you expound on step 2? Are you saying the wan on the USG is 192.168.1.x? I think the default is 192.168.1.130. 

What if I may ask is your internal IP range behind the USG ? 

Otherwise I have setup the same way you did yet I still can't get traffic through. This is a deal breaker so I am hopeful I can get this to work.

 

I wish they would give us bridge mode, but this setup should still work.

 

Anyway, appreciate the help. I called support and they are told to skip NAT and are not trained so they can't help.

 

 

This solution has not worked for me. I am wondering if there is a difference in the functionality of the DMZ and port forwarding between hardware versions of this router. I’ve had mine since jan/feb, so it’s pretty old. Neither feature seems to actually DO anything on my end.

In case it helps anyone, my firmware/hardware version are below. 

We definitely need Bridge Mode on the next iteration of this hardware if this is going to be considered comparable to other ISPs.

 

DETAILS:

Firmware version installed: 

02944

Hardware version 

REV.5

Badge

I have to say I agree.  Everything was working perfectly with a different LTE modem I had connected to my EdgeRouter X.  I have extensive home automation.  I saw that there is no bridge modem for this “you have to take everything except nothing” all-in-one from TMobile, so just plugged my router into the LAN port and nothing worked.  After extensive looking around, I was just stuck.  I took the router out and tried to get the port forwarding all done in the all-in-one from TMobile.  Some things work, but none of my home automation (through hassio if anyone knows that) is completely broken.  Now “Alexa” doesn’t know any of my lights, my heaters, my Ring lights, nothing.  I have to manually turn things on and off and I don’t see a way around it. And I take it we can’t use our own modem?  Speeds are great, but this looks like it’s meant for those who know nothing and can only handle a plug and play internet.

Unfortunately, until T-Mobile implements bridge mode, and offers static IP service, I cannot use them for my ISP.  :-(

Its not the internet unless you have a public IP address. Its a walled garden. ISPs went thru giving up on 100% NAT connections a decade ago. I really hope  T-Mobile fixes this soon as it is otherwise a very nice service.

I have the same issue as others. I’m running an extensive home automation setup and need a public IP at the edge where my home network  meets the Internet.