Inseego M2000 Doesnt Work For Gaming on 5G

  • 10 June 2021
  • 1 reply


I was told the 5G inseego MiFi 2000 would work with anything and would allow me to play Xbox One on it. I ended up connecting with my phone and laptop but unable to do so with my Xbox. I ended up messaging inseego because I thought it was an inseego issue. They replied to me saying this: 



The issue you are seeing is a result of some backend network handling changes made on the T-Mobiles side for their 5G network. Forcing the M2000 to 4G only is a possible fix for the issue while it is being worked out. This can be done with the following steps.

First, on a device connected to the M2000 open a browser and navigate to
Once you land on this page sign-in in the top right corner. (By default the admin password will be the same as the default WiFi password if it has not been updated)
Go to Settings > Advanced, the page you land on after clicking Advanced should be the Network tab, locate Network Mode Selection, change this from Auto to LTE/UMTS, save the changes at the bottom of the page.
Reboot the M2000, this change may take a few minutes to take effect, retry the connection from your console.

Here is how to get a hold of us if needed.

Inseego Support
Phone: 877-698-6481


I switched to 4G LTE and was able to finally get online for the Xbox Multiplayer. I wouldn’t of bought a 5G hotspot if I was going to have to only use 4G LTE. I got this because I’m away half the year due to work. Is T-Mobile going to have this issue fixed or will this be a continuous problem? If it won’t be fixed, I’d probably go in a different direction regarding providers

1 reply

Userlevel 6
Badge +14

This is a good question. A couple things. I’d make sure the device is updated to the latest version. After that, make sure to restart it and try connecting to 5G again. You could then have our Tech Care team file a Trouble Ticket for this issue. Just a headsup, though you can us 5G services for casual gaming, but isn’t recommended for competitive gaming.