Inseego M2000 Doesnt Work For Gaming on 5G

Show first post

32 replies

This does indeed work^ also they just fixed it where I live Holland-MI

I’m glad it helped you. Any other issues I can try to figure it out 

Do you or anyone know where t mobile gets there panel antennas from on there towers? I mess around with other modems and signal amplifiers. I have made some mini cells outside my home but cant find much on where they obtain there technology. 

Indeed I do 

Does anyone know where we can see official status (maybe a map?) on this issue?


1) Go to (Your hotspot admin site) on a device that your hotspot is connected to.

2)Go to Settings>Advanced>Networks

3)Under APN Settings select add APN

​​​​​​​4)Add “” and Save Changes

5)Reboot Hotspot


Hey Guys!

Sorry to join the party late, but I got really tired on playing on the slow 4G LTE service when I’m clearly paying for 5G! 

Below, I copied and pasted the instructions that were sent to me by the Inseego Engineer. It actually worked the first time too. 

As long as you follow the instructions, you should be good to go!


  • First, I will explain the main goal of this process. On the touch screen of the M2000 go to Menu > About, locate the IP address at the bottom of the About section. The IP address will read, this is what the M2000 thinks its internet IP is. The goal is to get this to a different IP address, something other than
  • Next, on a device connected to the hotspot, open a browser and navigate to
  • Once you land on this page sign-in in the top right corner. (By default the admin password will be the same as the default WiFi password if it has not been updated, If the password has not been updated it will prompt you to do so.)
  • Go to Settings > Advanced, you will want to be on the Network tab under advanced, scroll down, and locate APN, add a custom APN and enter all lowercase with the capital F. save the changes below.  Hold the power button on the hotspot and choose the option to restart it.  After the device regains service try using any application that was failing.
  • (If you are on a phone, these options will be in a pop-out menu on the left-hand side)

Hopefully this helps some people out :)


@Carlos9: This is very likely the same problem as this one, except that the solution communicated to you by the Inseego engineer doesn’t say anything about changing the PDP field to IPV4. As such, it may be that the latter move is unnecessary, which I intend to find out asap.



I was told the 5G inseego MiFi 2000 would work with anything and would allow me to play Xbox One on it. I ended up connecting with my phone and laptop but unable to do so with my Xbox. I ended up messaging inseego because I thought it was an inseego issue. They replied to me saying this: 



The issue you are seeing is a result of some backend network handling changes made on the T-Mobiles side for their 5G network. Forcing the M2000 to 4G only is a possible fix for the issue while it is being worked out. This can be done with the following steps.

First, on a device connected to the M2000 open a browser and navigate to
Once you land on this page sign-in in the top right corner. (By default the admin password will be the same as the default WiFi password if it has not been updated)
Go to Settings > Advanced, the page you land on after clicking Advanced should be the Network tab, locate Network Mode Selection, change this from Auto to LTE/UMTS, save the changes at the bottom of the page.
Reboot the M2000, this change may take a few minutes to take effect, retry the connection from your console.

Here is how to get a hold of us if needed.

Inseego Support
Phone: 877-698-6481


I switched to 4G LTE and was able to finally get online for the Xbox Multiplayer. I wouldn’t of bought a 5G hotspot if I was going to have to only use 4G LTE. I got this because I’m away half the year due to work. Is T-Mobile going to have this issue fixed or will this be a continuous problem? If it won’t be fixed, I’d probably go in a different direction regarding providers

in network settings change APN to b2b.T-Mobile and then change to IPV4 instead of IPV6 and it will work