Question

Anyone's Home Internet App not loading?

  • 12 November 2022
  • 33 replies
  • 7590 views

Badge

I had an issue and they reset my router/modem. The password reset and Im trying to change it back but I can’t load back into TMobile Home Internet App at all. Its stuck at loading.


33 replies

STILL BROKEN!!!

The app hasn’t worked since I got the internet several months ago. I’m beginning to think T-Mobile has killed all support for the wireless home internet product because there are tons of customers complaining about this and nothing being done.

I had an issue and they reset my router/modem. The password reset and Im trying to change it back but I can’t load back into TMobile Home Internet App at all. Its stuck at loading.

Disconnect all Amazon devices. I disconnected my FireStick and the TMobile app loads now. 

I’ve been struggling to connect with my iPhone 12… it used to work, then all the sudden it started getting glitchy and now I can’t log in at all.  
 

It’s so annoying… I did a complete factory reset twice trying to figure out what’s going on and then to find out it’s just the App??

-could you please take some time @TMobile and address this issue?? PLEASE??? 
 

I wasted hours of my life messing around with either my phone or the router.  Ugh…

Disconnect all Amazon devices. I disconnected my FireStick and the TMobile app loads now. 

We have an Alexa, disconnected it and it still won’t load.  It says to auto connect to my network and then you try to connect and nothing… you can try it over and over.  
 

I hope T Mobile updates this app… 

 

I had to factory reset my gateway after disconnecting the Alexa. Then I was able to connect the T-Mobile app. I hope this works for you. It is extremely frustrating. I get it. 
 

Also, the only work around for this to get a wireless access point and connect It to an Ethernet port on the gateway.  I haven’t tried it yet. My WAP just arrived today. 

Found a fix that's seems to be working. Logout out and get to the screen were it asks for the admin password. Enter it and uncheck the remember me box. You will have to enter the admin password every time but it will connect.

Tmobile should have been sble to fix this long ago. Seeing complaints over 2 years old. Shamefull.

Reply