Solved

Constant Voicemail "Received on Watch"

  • 22 March 2019
  • 42 replies
  • 28249 views

How do I get rid of the voicemail notification on my Galaxy watch? I have gone through my voicemails on my phone and deleted them all. I tried calling the voicemail from my watch notification and it just hangs up without calling. I even tried calling the number for my watch (which does not work). And the notification is still there...3 months later. At this point, it is just annoying. I have no voicemail and can't delete the notification on my watch, it says "Received on Watch" so nothing on phone's voicemail makes a difference, and it does not clear when I clear all the other notification on my watch. I just want to get rid of the notification.

icon

Best answer by tmo_mike_c 25 March 2019, 20:36

View original

42 replies

I resolved by turning off Bluetooth on both devices, restarted phone, then restarted watch but did not connect to phone.  Voicemail notification popped up on watch and I dialed from watch.  Of course, no voicemail, but I hung up and the notification was gone.  I then connected the phone and watch again.

t-Mobile tech here with the resolution: Make sure you have no unread VMs on your primary line (your phone). Next, disconnect your watch from your device (disable BT on your phone and also turn off wifi on the watch). Wait until your watch connects to T-Mobile for it's data connection on LTE. Call to your mobile phone from another number and leave a VM. Then, while keeping your watch and phone disconnected from eachother, call into VM (or us the VMM client) to listen to and delete the VM so that you no longer have any unread VMs in your account. This should send the VM MWI off message to the watch.

t-Mobile tech here with the resolution: Make sure you have no unread VMs on your primary line (your phone). Next, disconnect your watch from your device (disable BT on your phone and also turn off wifi on the watch). Wait until your watch connects to T-Mobile for it's data connection on LTE. Call to your mobile phone from another number and leave a VM. Then, while keeping your watch and phone disconnected from eachother, call into VM (or us the VMM client) to listen to and delete the VM so that you no longer have any unread VMs in your account. This should send the VM MWI off message to the watch.

Tried this and it didn't work 😞

t-Mobile tech here with the resolution: Make sure you have no unread VMs on your primary line (your phone). Next, disconnect your watch from your device (disable BT on your phone and also turn off wifi on the watch). Wait until your watch connects to T-Mobile for it's data connection on LTE. Call to your mobile phone from another number and leave a VM. Then, while keeping your watch and phone disconnected from eachother, call into VM (or us the VMM client) to listen to and delete the VM so that you no longer have any unread VMs in your account. This should send the VM MWI off message to the watch.

6 months ago, that worked for me, and every month since then. Now the problem has gotten worse, and this no longer fixes my issue. 

I don’t feel like anyone is adequately trying to help or resolve this multi-year software issue. 


 

Same. My previous watch had this issue and now my current watch just started doing it out of the blue after having the watch for like a year. It was actually part of why I switched to a new watch. I'll sooner switch companies before getting yet another watch because they can't get this issue under control. 

What's funny is in the Samsung community, the tech there pushes puerile to check out this thread for answers... essentially saying this is a T-Mobile specific issue. 

I FOUND THE SOLUTION 100% FIX

The trick to fixing the voicemail notification issue is to set and then disable the voicemail password. You'll still need to use the password when checking your voicemail from other phones. The watch fails to check the voicemail when it encounters a password prompt and for some reason defaults to showing a notification when it can't determine if there are voicemails or not.

 

You can do this by calling into your voicemail, press 5 for password security, then press 2 to turn off password/pin when calling VM from your number. (You will still need your pin when calling your VM from another number). 

 

This literally fixed my issue right away. I was dealing with this nonsense for years. 

Userlevel 4
Badge +5

I FOUND THE SOLUTION 100% FIX

The trick to fixing the voicemail notification issue is to set and then disable the voicemail password. You'll still need to use the password when checking your voicemail from other phones. The watch fails to check the voicemail when it encounters a password prompt and for some reason defaults to showing a notification when it can't determine if there are voicemails or not.

 

You can do this by calling into your voicemail, press 5 for password security, then press 2 to turn off password/pin when calling VM from your number. (You will still need your pin when calling your VM from another number). 

 

This literally fixed my issue right away. I was dealing with this nonsense for years. 

Would you need to make this call from your watch or your phone?

I don't think it matters. You just have to disable the need for the pin when calling your voicemail from your line. I did it on my phone because it was easier. 

I resolved by turning off Bluetooth on both devices, restarted phone, then restarted watch but did not connect to phone.  Voicemail notification popped up on watch and I dialed from watch.  Of course, no voicemail, but I hung up and the notification was gone.  I then connected the phone and watch again.

This works but you have to make sure you wait until the voicemail recording says goodbye after you press ** to ensure it clears. Then reconnect Bluetooth to watch. It has worked for me so far. This fix came from the Samsung community. 

https://us.community.samsung.com/t5/Galaxy-Watch/Galaxy-Watch-series-persistent-voicemail-notifications-Samsung/m-p/2662296#M73226

I was able to get rid of the annoying ongoing voicemail notification by setting up my voicemail on my watch without my phone around me after I restarted my watch 5 and well there was a actual voicemail on my watch voicemail and now it's been deleted 

The fix that has worked consistently for me, is removing the data plan from the watch and then reinstalling it. 

Settings->connections->mobile networks->mobile plans->remove all mobile plans.

 

Then reinstall it using the Samsung wear app.

Watch settings->mobile plans.

 

Good luck.

none of the previously mentioned solution attempts in this thread worked for my Samsung Galaxy Watch 5. it took 5 T-Mobile reps to get it fixed. watch factory reset AND a new eSIM/data plan was needed. it was a huge mess. I really hope it doesn't recur.

Go to wearable app, go to watch settings, go to mobile plans section, go to 3 dots at the top, hit remove mobile plan, remove all mobile plans, click "I'll contact tmobile to cancel my plan if i dont need it anymore", hit reset, then add it back by hitting top right button, then add it back-hit next, reconnect this watch, use plan. 

 

Here's a video https://youtu.be/esDg3cblPj8?feature=shared

 

You're welcome. Racked my brain until I found this. 

Go to wearable app, go to watch settings, go to mobile plans section, go to 3 dots at the top, hit remove mobile plan, remove all mobile plans, click "I'll contact tmobile to cancel my plan if i dont need it anymore", hit reset, then add it back by hitting top right button, then add it back-hit next, reconnect this watch, use plan. 

 

Here's a video https://youtu.be/esDg3cblPj8?feature=shared

 

You're welcome. Racked my brain until I found this. 

this didn't work for me. a full factory reset plus T-Mobile had to create a whole new eSIM/data plan is what finally worked for me.

I shut off the plan on the watch and the notification went away. Pretty annoying that nothing else like resetting or rebooting hasn’t worked. Probably not the correct way to handle that, and probably not t-mobile approved, but it worked. The directions given didn’t even match what the app gave me in my phone. That whole 3 dots do not give me the options that the tech rep described. 

Badge

None of the previous solutions were working for me. Finally managed to clear it.

  • Disconnect from phone, leave yourself a VM, clear it over LTE.. did not work.
  • Connect phone and remove then re-add data plan… did not work.
  • Call VM from watch while connected to phone BT…
    • watch took forever just trying to call VM
    • finally got a… busy signal?
    • call disconnected and VM notification was gone.

Why? No clue. Was it something to do with removing/re-adding the data plan that caused the VM call from watch through the phone to reset something? No idea. Will this last? Who knows!

Just wanted to share in case this somehow works for someone else.

After trying most the hack style fixes here and nothing working i called TM tech support. They were not able to help. What finally worked was removing the data plan via the “wear” app and then reconnecting. This is the same fix 

  • IvyMallory mentioned 

    I dont think you need a TM rep on the phone with you but i would recomend it because it possible e new plan may be started and I dont know wat you unique set up is with adding lines 

Reply