Solved

How do you get ID without a T-Mobile phone number (for Home Internet)

  • 17 February 2022
  • 60 replies
  • 15408 views


Show first post

60 replies

I'm  having the exact same problem and get the same error codes. Now I can't even redeem my promo mastercard.

That’s what I asked above. Hopefully they will allow us to redeem it in another way.

@HeavenM Additionally, I was offered a $50 rebate as a new customer through a prepaid card. I tried to login to redeem my rebate, but the phone number barrier in the account that is the issue described in this thread is preventing me from obtaining the rebate. The rebate has a deadline. Do you know another way I could still claim it? Thank you.

From HeavenM:  “Hey folks! I am making some headway on this situation, but I do need to clarify one thing. When you enter the name, email, and password into the signup page that I linked, you should receive an email with a one-time PIN in your email. Even though it is asking for the phone number on the next screen, has anyone received that one-time pin while working in this loop?”

 

Yes. I receive the one-time confirmation code (PIN) every time I try to log-in. The one-time confirmation code is sent to the email that I used when signing up for T-Mobile internet. Unfortunately, when I enter the confirmation code, the next screen requests a phone number. As noted in a previous posting, if entering a non-T-Mobile phone number, the error message is that I need to verify that the T-Mobile phone number is correct (see screenshot above). If I enter the internet line number on the T-Mobile gateway, the error message is that my email is not recognized (again, see screenshot above). My T-Mobile gateway is able to receive messages -- e.g. when my auto-pay processes I receive a message on the gateway; when I phone customer service I receive follow-up messages.

 

How was BChat able to get access to their account? What is the trick?

I really appreciate everyone that let us know something was not working and providing examples and details. These have been extremely helpful and let us figure out what was missing. If you contact our customer support teams, there is a new process they can file to quickly resolve the registration issues. 

You can call our customer support number or send us a direct message on Facebook or Twitter. 

Thank you. Another question I have for you @HeavenM 

Is it possible to port forward in the modem configuration or make modifications there? When I login at the IP gateway address, the user interface is very bare bones.

How can this issue be shown as SOLVED. Maybe that one user has received their Tmobile ID but most of us have not had this issue resolved! I have been on the phone NUMEROUS times with customer service. The only response I get is that they are working on resolution. This is ridiculous.

I'm  having the exact same problem and get the same error codes. Now I can't even redeem my promo mastercard.

Userlevel 2
Badge

I was contacted by HeavenM (I think he is an admin in the T-Mobile Internet Forum).  Once he verified my name, username and gateway number, he created a trouble ticket.  Later that day (on my own) I tried to logon using my gateway number (previously I used a non-T-Mobile number) and WAS ABLE TO LOGON.  INCREDIBLE!  Not sure what the “admin” (HeavenM) did or had done but possibly he associated my gateway number to my account.  Sorry, I cannot provide more specific details but I don’t have them.  All I can say is, whatever he did, IT WORKED!  Good luck.

Userlevel 7
Badge +13

From HeavenM:  “Hey folks! I am making some headway on this situation, but I do need to clarify one thing. When you enter the name, email, and password into the signup page that I linked, you should receive an email with a one-time PIN in your email. Even though it is asking for the phone number on the next screen, has anyone received that one-time pin while working in this loop?”

 

Yes. I receive the one-time confirmation code (PIN) every time I try to log-in. The one-time confirmation code is sent to the email that I used when signing up for T-Mobile internet. Unfortunately, when I enter the confirmation code, the next screen requests a phone number. As noted in a previous posting, if entering a non-T-Mobile phone number, the error message is that I need to verify that the T-Mobile phone number is correct (see screenshot above). If I enter the internet line number on the T-Mobile gateway, the error message is that my email is not recognized (again, see screenshot above). My T-Mobile gateway is able to receive messages -- e.g. when my auto-pay processes I receive a message on the gateway; when I phone customer service I receive follow-up messages.

 

How was BChat able to get access to their account? What is the trick?

I really appreciate everyone that let us know something was not working and providing examples and details. These have been extremely helpful and let us figure out what was missing. If you contact our customer support teams, there is a new process they can file to quickly resolve the registration issues. 

You can call our customer support number or send us a direct message on Facebook or Twitter. 

Hey folks! I am making some headway on this situation, but I do need to clarify one thing. When you enter the name, email, and password into the signup page that I linked, you should receive an email with a one-time PIN in your email. Even though it is asking for the phone number on the next screen, has anyone received that one-time pin while working in this loop?

Yes, I received this. After entering the code from my email, it takes me to the phone number page, which is where I, and others, are stuck. It is the process described above in the screenshots by Major Rathbone.

Thank you for letting me know that you get the PIN. You don’t have to put your email address in this thread (because we don’t want that to be shown to the public), but are you using the same email that you used to register for the Community?

No problem! Yes, I am using the same email for my ID, 5g registration at the T-Mobile store, and for this forum. 

Userlevel 3
Badge

From HeavenM:  “Hey folks! I am making some headway on this situation, but I do need to clarify one thing. When you enter the name, email, and password into the signup page that I linked, you should receive an email with a one-time PIN in your email. Even though it is asking for the phone number on the next screen, has anyone received that one-time pin while working in this loop?”

 

Yes. I receive the one-time confirmation code (PIN) every time I try to log-in. The one-time confirmation code is sent to the email that I used when signing up for T-Mobile internet. Unfortunately, when I enter the confirmation code, the next screen requests a phone number. As noted in a previous posting, if entering a non-T-Mobile phone number, the error message is that I need to verify that the T-Mobile phone number is correct (see screenshot above). If I enter the internet line number on the T-Mobile gateway, the error message is that my email is not recognized (again, see screenshot above). My T-Mobile gateway is able to receive messages -- e.g. when my auto-pay processes I receive a message on the gateway; when I phone customer service I receive follow-up messages.

 

How was BChat able to get access to their account? What is the trick?

Userlevel 7
Badge +13

Hey folks! I am making some headway on this situation, but I do need to clarify one thing. When you enter the name, email, and password into the signup page that I linked, you should receive an email with a one-time PIN in your email. Even though it is asking for the phone number on the next screen, has anyone received that one-time pin while working in this loop?

Yes, I received this. After entering the code from my email, it takes me to the phone number page, which is where I, and others, are stuck. It is the process described above in the screenshots by Major Rathbone.

Thank you for letting me know that you get the PIN. You don’t have to put your email address in this thread (because we don’t want that to be shown to the public), but are you using the same email that you used to register for the Community?

Userlevel 7
Badge +13
  • HeavenM helped me get online account access today.  I verified my gateway #, name and username and was able to logon within 2 hours.  I am so happy I can barely write this email (I hope I am not dreaming).  

  • HeavenM is the GREATEST!

  • Just FYI to everyone.  Hopefully you will also get access soon.

 

Hope @HeavenM isn’t a casualty of today’s massive layoffs.

 

 

The recent layoffs are heartbreaking. I can gladly say that I am still here to continue to help all of you and manage this great site. 😁

BChat is correct -- “Just more information but not the answer!”

The Sign-up page linked in HeavenM’s message requests first and last name, email, and password. When I click the “Create T-Mobile ID” button, the next screen that pops up is the “Link your phone number to your T-Mobile account.”

 

If I put in a non-T-Mobile phone number, the error message is that I need to put in a T-Mobile phone number.

 

When I put in the phone number on the 5G internet gateway (modem), the error message is that my email is not recognized, and yet on the Sign-In page I put in my email and it was confirmed that my account has been created.

 

It is a never-ending maze of dead ends.

If someone has the answer, please help. I have contacted T-Mobile customer service numerous times  and, despite being friendly and courteous, no customer service agent has been able to assist.

 

@HeavenM this is what I was referring to above, and this is where I am also stuck. I believe MajorRathbone is still stuck here too. See this thread

Hey folks! I am making some headway on this situation, but I do need to clarify one thing. When you enter the name, email, and password into the signup page that I linked, you should receive an email with a one-time PIN in your email. Even though it is asking for the phone number on the next screen, has anyone received that one-time pin while working in this loop?

Yes, I received this. After entering the code from my email, it takes me to the phone number page, which is where I, and others, are stuck. It is the process described above in the screenshots by Major Rathbone.

Userlevel 6
Badge +9
  • HeavenM helped me get online account access today.  I verified my gateway #, name and username and was able to logon within 2 hours.  I am so happy I can barely write this email (I hope I am not dreaming).  

  • HeavenM is the GREATEST!

  • Just FYI to everyone.  Hopefully you will also get access soon.

 

Hope @HeavenM isn’t a casualty of today’s massive layoffs.

 

 

Userlevel 2
Badge
  • HeavenM helped me get online account access today.  I verified my gateway #, name and username and was able to logon within 2 hours.  I am so happy I can barely write this email (I hope I am not dreaming).  

  • HeavenM is the GREATEST!

  • Just FYI to everyone.  Hopefully you will also get access soon.

Userlevel 5
Badge +7

Hey folks! I am making some headway on this situation, but I do need to clarify one thing. When you enter the name, email, and password into the signup page that I linked, you should receive an email with a one-time PIN in your email. Even though it is asking for the phone number on the next screen, has anyone received that one-time pin while working in this loop?

@HeavenM  I have never gotten that far.  This is the message I get:

We're sorry, we don't recognize this email. Please provide the email you used when purchasing your T-Mobile service, or contact Care by dialing 1-800-937-8997 or 611 from your T-Mobile phone.

Userlevel 7
Badge +13

Hey folks! I am making some headway on this situation, but I do need to clarify one thing. When you enter the name, email, and password into the signup page that I linked, you should receive an email with a one-time PIN in your email. Even though it is asking for the phone number on the next screen, has anyone received that one-time pin while working in this loop?

I am also having the issues described above.  

I used to have an account for a sim card data plan that never worked in the area where I wanted to use it.  Stopped using it long ago.

A few weeks ago I purchased the Home Internet service in the town in which I plan to use it; not where I actually live.  I don’t have local access to the device.

When I got into this strange loop, out of desperation, I called support and over the course of about 2 hours and 2 calls to different support persons, I finally got auto-pay set up manually.

However, neither of the support people could help with the account with no T-Mobile number.  How lame.

One of the support people said I should use the app and in that case, it asks right up front that I should connect to the t-mobile wifi device.  We’ll no device means you can’t use the app. 

Come on T-Mobile, this isn’t rocket science, it’s a web page.  This is just stupid tedium you’re throwing at your users.

My bigger problem is how to get around CG-NAT so I do things like control gates, an irrigation system, or we cams.  Neither of the support persons had ever heard of the CG-NAT problem.

Very frustrating.

Thank @MajorRathbone Your process is exactly what I have been experiencing. I am new to TMobile and only have the 5G gateway and I was going to sign up for the Ooma VOip service. But the Ooma VOip service requires me to log into my Tmobile account using my Tmobile ID which is of course not linked to my gateway device because the t-mobile home gateway isn’t recognized by the Tmobile system.!! 10 days and still no progress…..

Userlevel 5
Badge +7

@HeavenM add me to the list of people in this boat.  I am quite satisfied with the internet service, and I was able to get Autopay set up over the phone, with the $5 discount.  However, I am disappointed that I am unlikely to ever get the $50 virtual card for switching.

You would think that a customer could set up an online account with the gateway phone number and the account number and/or service address, and use whatever email address they wanted.

Userlevel 7
Badge +13

Thank you so much for the extra details. I am still working with our Home Internet peeps to see why this is not working and what we can do to fix it. 

I love that you have the autopay set up and things are good for now, but I want to make sure that we do our due diligence when it comes to our systems working as intended. 

Userlevel 3
Badge

BChat, I definitely agree. Other than not being able to access an account I am happy with T-Mobile  5G internet so far.

It is frustrating and makes no sense that T-Mobile cannot allow customers to create an ID and access their own account.

I have spent more than 10 hours on this snipe hunt. Hopefully, HeavenM, as a Community Manager, can get some answers.

Userlevel 2
Badge

I like to solve issues, not give up on them but in this case (if I were you) I would put this on the back burner (I have).  My internet works fine, autopay is working, I get my $5.00 discount for autopay and I get a paper bill about 10 - 14 days prior to the autopay date.  Good luck but if you come up with a solution please post it.

Userlevel 3
Badge

Hello HeavenM. Thanks very much for following up on this. As BChat wrote, “...the frustration of setting up the account (with a non-T-Mobile cellphone) has worn me down.” I agree with that completely.

I signed up for T-Mobile 5G Internet online on April 14.

That same April 14 I received three emails from T-Mobile: “You’re In” (essentially a welcome message), T-Mobile Order Confirmation, and T-Mobile Service Agreement. On April 17 I received an email that my order (gateway/modem) had shipped.

On April 22, the day I connected my internet and got it up and running, I tried to create a T-Mobile ID and kept getting the error message “We’re sorry, we don’t recognize this email. Please provide the email you used when purchasing your T-Mobile service...” When I contacted Customer Service the person told me that my account was locked, but the customer service person said they unlocked it; however, I was told that the “Create a T-Mobile ID” page was having problems and so I should try again in a day or two.

A day or two later I was still getting the same error message: “We’re sorry, we don’t recognize this email...” Yet, as noted above, I had received four email messages to the email account I used when ordering internet service.

On April 25 or 26 I phoned Customer Service again and was told that it appeared that the person who took my order did not enter my email address (which clearly was not true since, as noted above, I had received four emails to my email account). This Customer Service person said they would put me in touch with a technician.

In the meantime, I tried multiple variations of my email address -- all lower case, ALL CAPS,  and since my email is my name, I tried capitalizing the first letter of my first name, the first letter of my last name, etc., etc. Nothing worked; I kept getting the same error message: “We’re sorry, we don’t recognize this email...”

The technician contacted me a few days later and accessed my account and after about 10 minutes said that he found a way to enter my email, which he did. He said to give it 48-72 hours and then I would be able to set up my T-Mobile ID. Wrong. Still the same error message: “We’re sorry, we don’t recognize this email...”

I phoned Customer Service again on April 30 and got an international technician who took a long time trying to figure out what was wrong. After some time, the person said that they would submit a ticket and I would hear from technical support within 72 hours. I never heard back.

On May 4 I used the Chat option and explained the issue in detail. Unfortunately, after being on a 30 minute wait that person simply recommended going to t-mobile.com/isp to create an ID since that page is for Internet Only customers. Of course, I had previously been at that page and I was not able to create a T-Mobile ID.

I was about ready to give up. After all, like ChatB, I am on Autopay (I set that up online when initially ordering the internet service) and so I guess that was as good as things could get.

I was still getting regular emails from T-Mobile, mostly marketing emails. On May 10, I received an email titled “Give your T-Mobile home internet an edge.” That email essentially provided tips on how to set up the T-Mobile gateway (even though I had set up my T-Mobile internet three weeks earlier). When I clicked on the link in the email I was taken to https://www.t-mobile.com/support/home-internet. Near the bottom of that page there was a section titled, “Still need help?” with a link: “Go to T-Mobile Community.” Having tried everything else, I thought, why not; let me see what the Community might have to offer. In order to make a posting I needed to sign in. I figured that would be futile, but I gave it a try, and voila, I was logged into the Community and able to make a posting. When I went back to my personal email, I had received an email message  titled “Welcome to My T-Mobile,” which included the message that my “T-Mobile ID is officially ready to use.” Wow! I had created a T-Mobile ID. I was so excited.

Unfortunately, when I go to the T-Mobile website and try to log into my T-Mobile account, I run into the problems noted in my previous posting (the one with screenshots) -- if I enter a non-T-Mobile phone number I get the error message that I need to verify my 10-digit T-Mobile telephone number. If I enter the telephone number on my 5G internet gateway, I get the error message “We’re sorry, we don’t recognize this email” (which contradicts all of the previous emails, including the one titled “Welcome to My T-Mobile” notifying me that my “T-Mobile ID is officially ready to use”).

I have received numerous (text) messages on my T-Mobile gateway device, such as follow-up messages from Customer Service, so I know that the internet line number is functioning and is in the T-Mobile system.

I have tried to log into my T-Mobile account on the main T-Mobile webpage, the t-mobile.com/isp webpage, as well as using the “My account” pulldown menu in the upper right corner on the T-Mobile Community webpage, as well as the T-Mobile app.

I have tried different web browsers, and different days of the week, and different times.

As described in my previous posting I can enter my email and password, but I hit a dead end on the page that asks for a telephone number.

Thanks again for following up on this. If you need more information, let me know.

Userlevel 2
Badge

Signed up over the phone? YES.

Do you have the confirmation email from when you signed up?  YES.

My information MATCH 100%.  I have gone over the information numerous times with Customer Care since early April 2023.

I appreciate all the comments but this should be a simple issue to resolve for Technical Support.  Instead, it is not being address and everyone seems to just keep kicking the can down the road.

Reply