Galaxy Watch LTE duplicate messages

Show first post

157 replies

Sorry Amanda, I spoke too soon! All the messages from the last 3 days came thru about an hour ago when I walked out in my back yard. Weird thing is it had disconnected numerous times in the last few days. Why it chose tonight I have no idea.

Userlevel 3

@dupsla​, YAY! Good news! 😊 I'm happy to read that everything is looking up with your watch! Thank you for the update.

Thank you for that detailed info, @magenta6238774​! Let me send that to my Samsung team to see what other suggestions they have. I may say this a million times in this thread but I truly do appreciate you taking the time to try each different configuration then getting back to me with the outcome.

Mine seems to be working now. I haven't noticed 100's of txt coming thru when it disconnects from my phone anymore. I did have a trouble ticket in and also followed your recommendations. I did toggle the remote connection in the settings. So which ever worked I don't know, but I'm happy right now! I have noticed the battery life is not as low at the end of the day, it's around 50% not 20%.  So it defiantly is on its way to being as good as the s3. 😉

Hello. I tried both routes from the thread.

With DIGITS for the watch disabled and bluetooth / wireless connection

on, things work well. However, then the watch won't connect to the phone

number on LTE.

With DIGITS enabled for the watch and bluetooth / wireless connection

off, the phone and watch get copies of all messages somewhat

simultaneously. Sort of works, but as other noted, involves heavy

battery drain.

It isn't really a good solution to have to log in to enable / disable

DIGITS each time the watch is to be used separate from the phone. It

also takes time for enable / disable to take effect; a few minutes but

the point is to be able to go use the watch (for a run, for example)

without the phone. Inconvenient to have to wait some time before heading


So, no good solution.

Userlevel 3

Hey, All!

I just wanted to stop by to see if the duplicate texts have stopped after the suggested steps I provided last week. I'd like to give an update to my Samsung team on whether or not this worked. 😊

Userlevel 3

@magenta6238774​, no, I do not believe so. DIGITS should be disabled and remote connection enabled to prevent the duplicate texts. Can you confirm if this is how your watch is set up and how it functions with the setup?

@dupsla  - I'm happy to hear that the phone number issue seems to be fixed!

Sorry I should have been a little clearer, I was speaking of the rep. He had me send him pictures of the text coming thru as my watch #. It seems to be fixed as of now. Hopefully!

Hello, and welcome back!

I wanted to check, does remote connection refer to both Bluetooth and

WiFi connections? Using LTE alone (which would result from turning off

remote connections by my understanding) really drains battery.

No I don't. I have my main number off in the app. When I spoke to the rep he said it's supposed to do that when it kicks over to Mobile networks/disconnects from bluetooth, all your messages are supposed to come thru. He said to turn on mobile networks on my watch to stay on all the time. My watch was dead in 3 hours. I had 100's of messages come thru at a time. Another issue I am having and I sent him pictures, I have 2 contacts when they text me it comes thru as if its from my watch number.

Userlevel 4
Badge +10

A good question would be do you have the DIGITS app (native or otherwise) enabled on your phone with your phone number? I ask mostly out of curiosity because when I have mine on, I get multiple notifications from DIGITS regarding messages that I've already read in my regular Android Messages app.

Userlevel 3

Thanks for getting back to me, @magenta6238774​! Sorry for the delayed response as I was out of the office for a few days. If DIGITS is enabled, the remote connection should be off. Can you make sure your Watch is set-up that way and let me know if the duplicate texts still come in when you step away from your phone?

Hello, @dupsla​! We're working on a fix now and you're welcome to join in the troubleshooting conversation, if you'd like. I'm working with a few people from T-Mobile and Samsung to get to the bottom of why this is happening.

Same issue as original poster. Has anyone found a fix? I tried the above and it did not work. I have called tmobile and they put in a ticket and told me it would be fixed in 72 hours. It's not.

After disconnect, DIGITS is enabled.

Thank you!

Userlevel 3

@magenta6238774, thank you for the detailed response. When you disconnect from Bluetooth do you have DIGITS enabled or disabled?

@floresr639​ , I'm sorry we didn't get this fixed in time but I appreciate you taking the time to help get the Watch working as it should be.

Yea im done with this stupid watch. $375 and we cant even get it to work correctly. RETURNED!

Hello, and thanks again for pursuing this solution. I wanted to test for

a few days before replying.

Unfortunately, it did not provide a good solution. On turning off that

setting and then back on, I didn't get duplicate messages. However, it

became clear that this was because all notifications from the messages

app. On reallowing messages to send notifications, I am once again

getting duplicate messages.

Some additional information, I am predominantly using the watch tethered

through bluetooth, with LTE in auto mode (turns on if bluetooth

disconnects). It is when the watch and phone get out of bluetooth range

that the duplicate messages arrive, perhaps 15 minutes after disconnect.

Userlevel 3

Happy almost Friday!

I just wanted to check in to see if anyone has had a chance to try the steps I posted a few days ago. If so, did the duplicate texts stop coming in once you connected to LTE?

Userlevel 3

Alrighty, I have a few steps for you guys to try.

  1. Launch Gear Manager
  2. Go to Watch connection
  3. Toggle Remote connection on
    Note: The first time you select "Remote Connection" it will ask you to log in to your Samsung account. Once you log in, forwarding will be enabled for your Watch that is connected to your handset.

Please give this a shot and let me know if that fixes the issue!

Thank you for pursuing this! I haven't given up hope on getting this issue resolved.

Thank you, hopefully the issue will be fixed soon

Userlevel 3

Hello, Everyone!

While some of you may have return the Galaxy Watch already and no longer need updates on the issue, I'd still like to keep this thread updated. My Samsung contact got back early from his time off which means I should hopefully have a response no later than tomorrow.

Look at all these returns, it’s nothing short of embarrassing. Go look anywhere on the internet everyone is talking about how the lte version doesn’t work lmao. Switched to an iPhone X and the Apple Watch series 3 and couldn’t be happier. Thank you for at least making the switch easy. Please stop seeing the galaxy watch until Samsung figures out lte.

Userlevel 3

Hey everyone,

I just received an update that the person that our Samsung guru will be out of the office until the end of next week so I will likely not have an answer for you until then. I'm incredibly sorry this is happening as I can't imagine how frustrating it is. If my Apple Watch did that, I honestly probably wouldn't use it as much as I do now. I'm going to keep searching for answers and different contacts in the meantime.

Yea im sending mine back as well,  screw this nonsense!

Still happening. Add to that the fact that LTE uses 20% of the battery per hour without even using the watch and this thing is going back to T-Mobile