Question

Stop sending my voicemails to SMS

  • 8 April 2021
  • 3 replies
  • 557 views

Badge

My voicemail messages are recorded correctly and the transcript is shown on my iPhone normally (Select the Phone icon, then the voicemail icon at the bottom). However, they also get sent to me as a text message (SMS). How do I stop the texting? Having the voicemail recording is sufficient - they’re normally just spam recordings anyway.


3 replies

I could have written your message myself! It’s exactly what I just explained to the T-Mobile support “expert” I got on the phone to get this “feature” turned off. She didn’t know what I was talking about, but after a lot of repeating myself she dug deeper to learn that it seems to be an error in the way my account is set up. She told me to hold on while she escalates the call so that I can talk to the technical team to get it fixed. 

….

After 30+ minutes on this call, much of it waiting, I’ve had a chance to explain the problem to the technical support person who has put me on hold again while he looks into it further. In other words, nobody seems to know what’s going on.

Userlevel 7
Badge +13

I've never had an iPhone but doesn't Apple do all the updates for their phones so if you update your phone through Apple then this may be an Apple issue with their visual voicemail app.

Anyone get a successful resolution yet?  It’s annoying as heck.  Not likely to keep T-Mobile when my iPhone 7 gets EOL’ed.

 

Reply