Question

OnePlus 8-5G Wifi Calling has no sound

  • 12 October 2020
  • 33 replies
  • 8119 views

Badge

My new OnePlus 8-5G phone (TMobile in US) cannot consistently send/receive wifi calls. Once answered, there is no sound on the OnePlus 8-5G phone while the other end can hear OK. I’ve tried updating the phone’s software (it is up to date) and I have updated the firmware on my router (which works with wifi calling with other phones: iPhone 11, iphone8, Droid Turbo 2, Motorlla Razr MAXX). I also tried disabling any battery saving features on the device and even did a factory rest of it (with no apps installed). I have also tried rebooting the phone once I have connected to the wifi router. Phone has same issues on any wifi router I have connected to. browsing is fine, only wifi calling is a problem.


33 replies

Userlevel 1

Probably not what you want to hear, but the 4 of these phones on my account all do the same thing. 

When I called in a service request about it to T-Mobile, they’re all like “have you tried factory resetting your phone?”

“So, I have to do that every day?”

“Um..  “

 

 

It is nice to know that this is not a unique problem and disturbing that their is no solution. Since it doesn’t seem limited to the One Plus 8, this appears to be a T-Mobile problem. What are you doing about it?

Same issue here my s21 is fine but with my wife's oneplus nord n10 she gets no sound when connected to a call using wifi calling. 

I just tried something that seemed to fix this on my Pixel 5:

I set Wi-Fi Calling to “Call over mobile network”, turned off “Carrier video calling”, turned on “Airplane Mode”, connected to the Wi-Fi and tried calling my voicemail. It worked, so I turned off “Airplane Mode” and it still works! The winning combo seems to be “Call over mobile network” and turning off “Carrier video calling”. Hope this helps someone else!

I’m having the exact same issue on my oneplus 8t 5g. Everyday I need to reset my phone to get Wi-Fi-calling to work. It will randomly stop working even in the middle of calls. Users are able to hear me, but I get no audio from my speaker, speakerphone, or connected Bluetooth accessories.

 

I’ve got a 1gig home internet circuit, Wi-Fi 6 5ghz network, and I’m literally right next to the access point. My device is fully patched.

T-Mobile, what is going on with your Wi-Fi calling network?!?! I switched from my galaxy s10 because of wifi calling issues on that device Galaxy Note 10 Wi-Fi Calling Preferences Updated Automatically | T-Mobile Community (t-mobile.com)

 

Userlevel 7
Badge +16

not limited to the OnePlus 8 no..but the majority of the devices running into this are running the Android  11 update though..

Userlevel 7
Badge +11

One Plus has MANY bugs.  As one with One PLus 8, and bluetooth issues, I’ve sent mine back for ‘warranty exchange’.  It appears (at least in my case) that the Android 11 update causes a whole ton of issues with several devices.  I’ve disabled WiFi on my 3rd device  :astonished:   (first 2 have Android 11 issues, unable to ‘undo’), awaiting One PLus 8 fix.

Any updates on this? Every time my phone switches from the network to wifi calling, I can’t hear the person on the other end but they can hear me.  

OnePlus 7 pro and 7T Pro user here, with the same problem since the Android 11 update. I sent OP with bug reports, nothing is happening.

hey there,

an option that is usually enabled by default on my most home routers is something called

SIP ALG

the location of this feature will vary according to which router you got but you wanna make sure this is disabled.

hopefully this will vastly improve your situation.  troubleshooting VoIP issues can be extremely difficult to isolate (hence t-mobile giving eryone the run around) but issues of one way audio, no audio and dropped calls can usually be blamed because SIP ALG is on.

g’luck and happy new year!

 

Is there a setting to fix the wifi calling issue introduced by Android 11 update? Could this be t-mo's implementation of WiFi calling?

Also the people at the t-mo store have never heard of this. The online support page didn't provide any answers. 

-Frustrated

Same issue with One Plus 9. Is it the Android 11 update? All started with that 11/1/2021 update. Will try the work arounds suggested. very frustrating.

Glad to hear it's not just me.

This problem is really frustrating. Hoping whoever is responsible will come out with a fix soon.

I have it especially bad, as I live in a basement with poor service so I rely on wifi calling…

I found that toggling wifi calling on and off sometimes helps but so far I don't see a pattern, it seems to be at random.

 

Userlevel 7
Badge +11

Typical OnePlus.   upgrades breaking features.   as much as I liked the hardware and ui, OnePlus bugs ended up with me trading for a Samsung s21 after 10 months of broken features that they won't fix.

I have the exact same issue with my Samsung Galaxy Flip Z 5G. When making or receiving calls with Wifi Calling enabled, I sometimes get no audio from the earpiece. Only a hard reboot seems to fix the issue (or disabling Wifi Calling). I’m running Android 11, build # ends in CUC6. I’ve had this issue for at least all of 2021 and possibly since I got the phone in Fall 2020.

Same problem here with the OnePlus Nord N10 5G, purchased two weeks ago. With wi-fi calling on, I can not hear callers. With wi-fi calling off, calls are fine. 

Very disappointing since I was hoping to use this device on an upcoming international trip. I would have preferred voice calls at $.00 a minute over wi-fi vs. having to pay $.20 a minute. 

Userlevel 7
Badge +11

OnePlus sends out upgrades often, but I agree on the Android 11 update, I'd be happy with my OnePlus 8, but they broke my Bluetooth vehicle connectivity… back in January, and still have yet to fix it.  I'm swapping this for a Samsung S21 while the $500 trade in exists.

Badge

Update - I’ve also tried replacing the SIM and toggling call mute/hold.

I contacted OnePlus and they first told me the problem was “already solved” and that I needed to contact TMobile for the fix (which, when I asked what it was, they said “The latest OTA update” which I already have). So no help there.

So far, the only thing that has worked for me, is to reboot the phone once I’m connected to the new WiFi network. But this doesn’t last- If I do this first thing in the morning, by afternoon I have to reboot again. SMS Text messages do not seem to work over wifi at all (send/receive) on this device.

Same, wifi calling not working on Oneplus8t+. Anyone with any update on resolving wifi-calling issue?

I was having the same problem and got it to work by setting ‘Calling preference’ to ‘Cellular preferred’ (the option is in the same place an ‘Enable Wi-Fi Calling on my OnePlus Nord N20).

My guess is ‘Cellular preferred’ has the phone connect using cellular, then switches to the network.  So not much help if you don’t have cell service, but it helps me as my cellular is just weak, but good enough to connect.

My family has been experiencing this as well, across OnePlus and Samsung devices. I just found this link on a Reddit thread and many users have reported it correcting this issue for them. It involves opening firewall ports up at your router. The article is filed under “WiFi calling on a corporate network” so how would we find it, right? Wi-Fi Calling on a corporate network | T-Mobile Support

Summary of the article:

Firewalls

IPv4 Address Block: 208.54.0.0/16:
PORT / PROTOCOL / DESCRIPTION
Port: 500 / UDP    / IPsec - IKE : Authentication [WFC 2.0]
Port: 4500 / UDP / IPsec - NAT traversal : Encrypted voice traffic [WFC  2.0]
Port: 5061 / TCP + UDP / SIP/TLS : Encrypted SIP [WFC 1.0]

IPv4 Address Block: 66.94.0.0/19:
PORT / PROTOCOL / DESCRIPTION
Port: 443 / TCP    / HTTPS : Used for handset authentication [WFC 1.0]
Port: 993 / TCP    / IMAP/SSL : Visual Voicemail [WFC 1.0]

Also whitelist the CRL server for DIGITS OTT and WFC 1.0: crl.t-mobile.com 206.29.177.36

Same issue, OnePlus 8T+

I have been on support calls with T-Mobile who always give me responses as defined in their process manual - to update 911 address. Don’t care if its an Android 11 issue, or a OnePlus Issue or a T-Mobile issue, someone just needs to fix this damn thing, because its started to affect my business now.

On a separate note, I am quite unhappy with my OnePlus 8T+ phone. Felt really good at the beginning, but the build quality on this phone is really poor and the phone just breaks so damn easily.

Lots of WiFi Calling problems here on the LG Thinq G8 since last summer.  The Wi-Fi pop ups kept happening so much I had to disable the always on display.  Lately I’ve had more friends complain it takes 30-60 seconds to connect a call to me.  Getting really fed up, my Samsung S7 never had any problems like this. I’m about to disable the WiFi calling all together (which was a major feature that kept me on Tmobile).

 

Maybe helpful, maybe not.  I have noticed that when my phone is on standby when pinging the WiFi IP address from a desktop on the same network I will get consistent crazy responses in the 200s and 300s.  If I wake the phone up and start to use it, those pings go to a normal 2-5ms range.  I was going to start looking in to a WiFi keep-awake app to try to prevent those high pings.

Same, wifi calling not working on Oneplus8t+. Anyone with any update on resolving wifi-calling issue?

There was a previous response that ended up working for me: https://community.t-mobile.com/network-coverage-5/oneplus-8-5g-wifi-calling-has-no-sound-32868?postid=131724#post131724

The key for me was to turn off “Carrier video calling”.

In the Settings app, either search for “Carrier video calling” or navigate “Network & Internet” > “SIMs” > “Carrier video calling”.

I restarted my phone just to be sure, called someone and could hear them on the other end.

This problem has been bugging me for years on my Pixel 5.

This is just ridiculous at this point. I work below ground and need wifi calling as my place of work has no TMobile coverage downstairs. One plus 8 5G, EVERYBODY is muted on ALL wifi calls until I turn off wifi calling.

 

This is my first and last phone with t mobile.

Reply